Leave a comment

Here are the accounts you need to change your passwords to

Here are the accounts you need to change your passwords to
Photo courtesy of Shutterstock

I'm sure you are aware of the "Heartbleed" bug by now.  Click here to find out why it's so dangerous and what you can do to stay safe. 

In short, the bug has affected two-thirds of all websites (don’t worry; my site was not affected) and could have compromised all your passwords, credit card information, Social Security numbers, encryption keys and more.

Security experts like me across the Web are encouraging everyone to change their account passwords, but what account passwords do you need to change?

Here's a quick list of the major sites that were affected. These are the accounts you need to take care of immediately:

  • Facebook
  • Tumblr
  • Google - including Gmail, Wallet, Play,
  • Yahoo - including Yahoo Mail
  • GoDaddy
  • Pinterest
  • Intuit
  • Dropbox
  • Minecraft
  • OkCupid
  • SoundCloud
  • Wunderlist

(Updated 4/10: LastPass has released information showing that its systems were not affected as originally thought.)

Here are the sites where information is still cloudy. Stay tuned to my blog to see what develops with these sites:

  • Twitter
  • Apple
  • H&R Block
  • Healthcare.gov
  • IRS
  • Netflix

 

Amazon is PAYING employees to quit
Previous Happening Now

Amazon is PAYING employees to quit

And the winner of the 2014 Worst Company in America award goes to ...
Next Happening Now

And the winner of the 2014 Worst Company in America award goes to ...

View Comments ()